Our extensions currently work with Joomla 3.1.1 to 3.7.x, and with PHP 5.3 to 5.6, and PHP 7. Sites run noticeably faster with PHP 7.

In order to prepare for Joomla 4, we are dropping support for older versions of Joomla 3 and making our minimum supported Joomla version 3.4.8.

We no longer provide extensions for Joomla 2.5 except for Eyesite, which will remain available for Joomla 2.5 until the end of 2017.

We strongly recommend that you keep your site up to date with the latest version of Joomla. From time to time significant security issues emerge, and sites that are not updated are quickly attacked once details of the problem are published. In general you can assume that our extensions work on new minor releases of Joomla, but if your site is critical to your business you should have a parallel test site where you can test upgrades before implementing them in your live site.

We will always offer our best advice, but if you want us to research a complex or time-consuming problem, it must be on the latest version of Joomla with the latest version of our product.

There's a table of Joomla versions and support dates at http://docs.joomla.org/Joomla!_CMS_versions