Most of our extensions work with Joomla 3.4.8 to 3.8.x, but we are moving towards a minimum requirement of Joomla 3.7.0 as we move towards compatibility with Joomla 4.

We no longer provide extensions for Joomla 2.5 except for Eyesite, which will remain available for Joomla 2.5 until the end of 2017.

Old versions of our paid extensions are available on request if you use an old version of Joomla, but we do not provide support for old versions of our products or old versions of Joomla.

We are actively working with Joomla 4 and will be ready for its release, sometime in mid-2018.

We strongly recommend that you keep your site up to date with the latest version of Joomla. From time to time significant security issues emerge, and sites that are not updated are quickly attacked once details of the problem are published. In general you can assume that our extensions work on new minor releases of Joomla, but if your site is critical to your business you should have a parallel test site where you can test upgrades before implementing them in your live site.

We will always offer our best advice, but if you want us to research a complex or time-consuming problem, it must be on the latest version of Joomla with the latest version of our product.

There's a table of Joomla versions and support dates at http://docs.joomla.org/Joomla!_CMS_versions

Our extensions currently work with PHP 5.3 to 5.6, and PHP 7. However, as of November 2017 we are developing and testing using PHP 7 only. If you have not yet upgraded to PHP 7 you should upgrade as soon as possible. Joomla 4 requires PHP 7 as a minimum, and sites do run noticeably faster with PHP 7.